summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:39:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:16 +0200
commit1e2412c2e4b566936653e98e62d244efd5523848 (patch)
tree7c2879e3d298f32b73ba32864fa2b31ce373255f /dev-python/catkin_pkg/catkin_pkg-9999.ebuild
parentros-meta/rqt: Bump to 0.5.0. (diff)
downloadgentoo-1e2412c2e4b566936653e98e62d244efd5523848.tar.gz
gentoo-1e2412c2e4b566936653e98e62d244efd5523848.tar.bz2
gentoo-1e2412c2e4b566936653e98e62d244efd5523848.zip
dev-python/catkin_pkg: Add patch by Tim Rakowski in bug #612860 to avoid infinite loop in crawling directories
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-9999.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index f86e76ef427c..28e56139aea2 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -34,7 +34,12 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" "${FILESDIR}/ros_packages.patch" )
+PATCHES=(
+ "${FILESDIR}/catkin_prefix.patch"
+ "${FILESDIR}/argparse.patch"
+ "${FILESDIR}/ros_packages.patch"
+ "${FILESDIR}/infinite_loop.patch"
+)
python_test() {
nosetests -s --tests test || die