summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-20 16:13:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-20 17:49:03 +0200
commit1318f5386e96fa3c2ba82f4be80b3b562a499060 (patch)
treec4f3bb4f0f6134d6c6bf92b0e13bcbb95afa7a65 /dev-python/cbor
parentdev-python/backports-abc: Remove py3 (diff)
downloadgentoo-1318f5386e96fa3c2ba82f4be80b3b562a499060.tar.gz
gentoo-1318f5386e96fa3c2ba82f4be80b3b562a499060.tar.bz2
gentoo-1318f5386e96fa3c2ba82f4be80b3b562a499060.zip
dev-python/cbor: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cbor')
-rw-r--r--dev-python/cbor/Manifest2
-rw-r--r--dev-python/cbor/cbor-1.0.0.ebuild15
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/cbor/Manifest b/dev-python/cbor/Manifest
index cccfa7fa6115..0909a13cb5db 100644
--- a/dev-python/cbor/Manifest
+++ b/dev-python/cbor/Manifest
@@ -1 +1 @@
-DIST cbor-1.0.0.tar.gz 20096 BLAKE2B 0e15bc4984155c1046836c94f3025f8dd451aaad438c78de25a739738e6de8d3ff3e737dbaeaace3d837be08e9702a3b7d18d840c0bc5459cd3919159eabd728 SHA512 996b61c7d16cbe8bd7b056d09286a17f3a6a29cb97ef9e5ca1d1bfe8c53393ae3d2b7565c937a283cb78f377af14c070bd663aabbce995dc7e5b9d2f69a6ba73
+DIST cbor-1.0.0.gh.tar.gz 25541 BLAKE2B dc5491235fee79ad15a8b92aafef2a690a407dfb98792e88b2e87fa7c354277b997ac314dc38279168f50c52f922de4bfe330b860126d4c5b836c019b05a1aee SHA512 88471b1c9c9a4128a4098194e17a4322ea2a01624ae1ffa9c33e433da31a089c45f4b64472d36620797488a451c16771c213b2b9a9ab711232c6658da4cd310f
diff --git a/dev-python/cbor/cbor-1.0.0.ebuild b/dev-python/cbor/cbor-1.0.0.ebuild
index 6a6e9b2d68de..a1d031b6ce97 100644
--- a/dev-python/cbor/cbor-1.0.0.ebuild
+++ b/dev-python/cbor/cbor-1.0.0.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
+EGIT_COMMIT="b3af679e7cf3e12d50acb83c3c591fc5db9a658d"
DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
-HOMEPAGE="https://bitbucket.org/bodhisnarkva/cbor https://pypi.org/project/cbor/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/brianolson/cbor_py
+ https://pypi.org/project/cbor/"
+SRC_URI="
+ https://github.com/brianolson/cbor_py/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/cbor_py-${EGIT_COMMIT}
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+distutils_enable_tests unittest