summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-09-01 17:06:42 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-09-01 18:03:32 +0000
commit686a9efcc4b316248c95af2fc002294765f6040a (patch)
tree57d47193d7c47cc382e8648e7d8b168e4c966797 /dev-python/ccdproc/ccdproc-1.1.0.ebuild
parentdev-php/PEAR-Net_URL2: Drop old (diff)
downloadgentoo-686a9efcc4b316248c95af2fc002294765f6040a.tar.gz
gentoo-686a9efcc4b316248c95af2fc002294765f6040a.tar.bz2
gentoo-686a9efcc4b316248c95af2fc002294765f6040a.zip
dev-python/ccdproc: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/ccdproc/ccdproc-1.1.0.ebuild')
-rw-r--r--dev-python/ccdproc/ccdproc-1.1.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ccdproc/ccdproc-1.1.0.ebuild b/dev-python/ccdproc/ccdproc-1.1.0.ebuild
new file mode 100644
index 000000000000..aae12007fbf8
--- /dev/null
+++ b/dev-python/ccdproc/ccdproc-1.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astropy affiliated package for reducing optical/IR CCD data"
+HOMEPAGE="https://github.com/astropy/ccdproc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DOCS=( README.rst )
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/astroscrappy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/reproject[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}