summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-17 19:48:02 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-17 19:48:15 +0200
commit672464c7ec456241a5a0bb747cb6c8fe6836b246 (patch)
tree05e3325be1b25537cb2d8f6a8d9c257541456ead /dev-python/cffi
parentdev-perl/Test-Trap: Remove legacy test fallback re bug #584238 (diff)
downloadgentoo-672464c7ec456241a5a0bb747cb6c8fe6836b246.tar.gz
gentoo-672464c7ec456241a5a0bb747cb6c8fe6836b246.tar.bz2
gentoo-672464c7ec456241a5a0bb747cb6c8fe6836b246.zip
dev-python/cffi: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index bb0d5ba0455b..5eea68fb2f5b 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,3 +1,4 @@
DIST cffi-1.2.1.tar.gz 335778 SHA256 eab571deb0a152e2f53c404c08a94870a131526896cad08cd43bf86ce3771e3d SHA512 26ab695d34ef1895f38c735b2c6400cbf6325d622ce93799513130791365bb71d656288e991b86861ac8e899872504c1f4368d27104c4ac9b881c83c7f8dad88 WHIRLPOOL a8bbe3c24be660946c1f31fbb8b1f50810f78b9485a32aadfb091a624b5386641bde71981c58792f8e95e8e77cfce7d9959eb197c417464cf5351e568aa6336d
DIST cffi-1.5.2.tar.gz 388793 SHA256 da9bde99872e46f7bb5cff40a9b1cc08406765efafb583c704de108b6cb821dd SHA512 3c707db85032bc13287beec0211d85a7b9f9dfcb87844adba3a86b23211acd495e88072ec23f22e7c7626d25cadd5b9843c34255d4080eefb171020ad0a2d552 WHIRLPOOL 35cfd86d06dcc2bb2a0e8e196f06d5df0eeaa6dd65d13dc4489284108fa596a88f46918c5b70e38584965290d141f5cbf0e2bcb469c3316cd1962109d77889dd
DIST cffi-1.6.0.tar.gz 397024 SHA256 a7f75c4ef2362c0a0e54657add0a6c509fecbfa3b3807bc0925f5cb1c9f927db SHA512 95dc7fbca624b5474ff0182ff6e1d1c6b8b34ad19c4c22cabf847f7be6c47dc32a96b23165da1c28438a46a1e9f681341fe8b7304ba5618744c595c4ae364466 WHIRLPOOL a4faef6dfaa078a09abadbe2af6d589dcd36d94bcf07eb47cda1e18ae1d60a3d62d0d66240f717f09564b97565b495e71b77390fe4278afb978fa2c62d341684
+DIST cffi-1.7.0.tar.gz 400251 SHA256 6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df SHA512 ce9439a219248b06a6f2d019324f4150576b5e4d853025d61d470105f95af2a6c2387080bfd0308c063ad756f34feead9a5958187d626524594dfe9a3adf7462 WHIRLPOOL 1d10ba1d5fe2dadfe239c2111e9eb08beeddb7b796e966dae642fbfef0d590737018e27e3036817a1b2f43d76d2526642022b0d2ebe97ce8fcf4a49c8006ea26
diff --git a/dev-python/cffi/cffi-1.7.0.ebuild b/dev-python/cffi/cffi-1.7.0.ebuild
new file mode 100644
index 000000000000..c54b5e66ab4c
--- /dev/null
+++ b/dev-python/cffi/cffi-1.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ einfo "$PYTHONPATH"
+ $PYTHON -c "import _cffi_backend as backend" || die
+ PYTHONPATH="${PYTHONPATH}" \
+ py.test -x -v \
+ --ignore testing/test_zintegration.py \
+ --ignore testing/embedding \
+ c/ testing/ \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}