summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 23:15:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 23:15:00 +0200
commit8e730db80c19c32643ec25b5b7a20cec7a987646 (patch)
tree041532eb66165646fb1dc4988875b395b59b1f6d /dev-python/cffi
parentnet-analyzer/nmbscan: Drop ~mips (diff)
downloadgentoo-8e730db80c19c32643ec25b5b7a20cec7a987646.tar.gz
gentoo-8e730db80c19c32643ec25b5b7a20cec7a987646.tar.bz2
gentoo-8e730db80c19c32643ec25b5b7a20cec7a987646.zip
dev-python/cffi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.14.6.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 1ef47710c4b5..d02ce8a9359e 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,2 +1 @@
-DIST cffi-1.14.6.tar.gz 475744 BLAKE2B 46e3f1f61746f659c066d83fdb07b83c289eda68056c6f9e364ea6f30cd56c190e4fdb35586c064b2402483704a7c1e9399d7f30cb49a78eec21797146da36f2 SHA512 30a8b25b74921a90a1fa96d05de1f25437d0fbbf73b7de0bb9ce22dfcaccbd78376b605525fe970212221d3e598357a9b1da420bfbd1a3e513263ed2b789e813
DIST cffi-1.15.0.tar.gz 484058 BLAKE2B 0d2d470c7eb11b8a9526be816b153c4483a5cfb529d3d220a804842facae1f06e2a822aa2be9abb1b5648cb36a97033bffc1dd235d83bdf8c075d67a907aa7d9 SHA512 ee83efde6f77f4a0c5889088c4c208ed7b9071fe06dfc16a8d2396de07f78fe859e1e39866760198a9d700f3b7359e8715e8a3e4907feb81d3fc4b8dd0dbaca1
diff --git a/dev-python/cffi/cffi-1.14.6.ebuild b/dev-python/cffi/cffi-1.14.6.ebuild
deleted file mode 100644
index 0f6aaa574f93..000000000000
--- a/dev-python/cffi/cffi-1.14.6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-DEPEND="dev-libs/libffi:="
-RDEPEND="${DEPEND}
- dev-python/pycparser[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
-)
-
-src_prepare() {
- if [[ ${CHOST} == *darwin* ]] ; then
- # Don't obsessively try to find libffi
- sed -i -e "s/.*\-iwithsysroot\/usr\/include\/ffi.*/\tpass/" setup.py || die
- fi
- distutils-r1_src_prepare
-}
-
-src_configure() {
- tc-export PKG_CONFIG
-}
-
-python_test() {
- "${EPYTHON}" -c "import _cffi_backend as backend" || die
- epytest \
- --ignore testing/test_zintegration.py \
- --ignore testing/embedding \
- c/ testing/
-}