summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-20 09:49:45 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-20 12:29:21 +0100
commitfc09b1fc40e335f9bec55db00dd63e5554f0b213 (patch)
tree97f41049bacd7c678b376ec3a86e1f9a8b09b647 /dev-python/cffi
parentdev-python/cffi: Add USE=test to install pytest buildtime only (diff)
downloadgentoo-fc09b1fc40e335f9bec55db00dd63e5554f0b213.tar.gz
gentoo-fc09b1fc40e335f9bec55db00dd63e5554f0b213.tar.bz2
gentoo-fc09b1fc40e335f9bec55db00dd63e5554f0b213.zip
dev-python/cffi: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.3.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index b52b383558df..a2c75c63a026 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,3 +1,4 @@
DIST cffi-1.1.2.tar.gz 326758 SHA256 390970b602708c91ddc73953bb6929e56291c18a4d80f360afa00fad8b6f3339 SHA512 d146984013b63382ea64bd2d6188cdbf9154cf83d66bf4dbb9353f1daea66f9eae07c6da47e152c5758d3458a742adde0310f71c792eb0a80950d7f857bfb943 WHIRLPOOL 02b92f0d13b02e351ba63e55a731c0b5480ae0b376c99a8dc1a256b3b55bf0119b4238dca88171605c1348b0847a6ff305ba4ec69cd1b42b9950708f42d6067e
DIST cffi-1.2.1.tar.gz 335778 SHA256 eab571deb0a152e2f53c404c08a94870a131526896cad08cd43bf86ce3771e3d SHA512 26ab695d34ef1895f38c735b2c6400cbf6325d622ce93799513130791365bb71d656288e991b86861ac8e899872504c1f4368d27104c4ac9b881c83c7f8dad88 WHIRLPOOL a8bbe3c24be660946c1f31fbb8b1f50810f78b9485a32aadfb091a624b5386641bde71981c58792f8e95e8e77cfce7d9959eb197c417464cf5351e568aa6336d
DIST cffi-1.3.0.tar.gz 347342 SHA256 9daa53aff0b5cf64c85c10eab7ce6776880d0ee71b78cedeae196ae82b6734e9 SHA512 2ea789d67782b2f23501bea4480f42f79e312d047e2d8c777aab8113400cfa136585aa92c0a51608a0da35cd6734bc24914fcccfc5bbdad3041aad2e9f784400 WHIRLPOOL 5daea22a7ad04a68aea0f962de8ff08c96b41d45539c43d2157ebc7f26799cf75f251b6b5c54901bc4f8e988791cc3ddefc52528b1c0ab3d3163adc56dea452a
+DIST cffi-1.3.1.tar.gz 351300 SHA256 d45dd39a770b4afb591c82555f6a8bbc1ac7eb019eda9b621eee1a0a72201220 SHA512 b89fe1b98a2e1492e05a9e69407104a5d5057dbe2730852fb91fae1db66751d35db53186d2f03dc950eb10dd9cecc83e44eb3e6954381dfd80d79519c7938288 WHIRLPOOL 37ea487ae7e5474a903cd259bac3428d04dc8f0ab0623edf8e12979e666d0779a04135e150073deb608a46b63084e51f66023e618637d3f71cc54f2eac84fdb9
diff --git a/dev-python/cffi/cffi-1.3.1.ebuild b/dev-python/cffi/cffi-1.3.1.ebuild
new file mode 100644
index 000000000000..ce2896f65967
--- /dev/null
+++ b/dev-python/cffi/cffi-1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}