summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-21 09:48:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-21 09:57:25 +0200
commit13aa81aea7b8314b064e163b59cf4c55c61f5b99 (patch)
treed73635d8761111209630ef28b8cd9187578e1d58 /dev-python/cftime/cftime-1.5.0.ebuild
parentdev-python/httpretty: Bump to 1.1.2 (diff)
downloadgentoo-13aa81aea7b8314b064e163b59cf4c55c61f5b99.tar.gz
gentoo-13aa81aea7b8314b064e163b59cf4c55c61f5b99.tar.bz2
gentoo-13aa81aea7b8314b064e163b59cf4c55c61f5b99.zip
dev-python/cftime: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cftime/cftime-1.5.0.ebuild')
-rw-r--r--dev-python/cftime/cftime-1.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cftime/cftime-1.5.0.ebuild b/dev-python/cftime/cftime-1.5.0.ebuild
new file mode 100644
index 000000000000..f192f36b4209
--- /dev/null
+++ b/dev-python/cftime/cftime-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="https://pypi.org/project/cftime/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e "/--cov/d" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}