summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/chameleon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/chameleon')
-rw-r--r--dev-python/chameleon/Manifest4
-rw-r--r--dev-python/chameleon/chameleon-2.16.ebuild41
-rw-r--r--dev-python/chameleon/chameleon-2.19.ebuild41
-rw-r--r--dev-python/chameleon/chameleon-2.20.ebuild41
-rw-r--r--dev-python/chameleon/chameleon-2.22.ebuild41
-rw-r--r--dev-python/chameleon/metadata.xml8
6 files changed, 176 insertions, 0 deletions
diff --git a/dev-python/chameleon/Manifest b/dev-python/chameleon/Manifest
new file mode 100644
index 000000000000..97fe410ad79b
--- /dev/null
+++ b/dev-python/chameleon/Manifest
@@ -0,0 +1,4 @@
+DIST Chameleon-2.16.tar.gz 200838 SHA256 87c82d657fbc1b47decbe605a6f6105d9190cb19e924b59262cfdfa03e7a512d SHA512 a6f1491a11e55231ed5304b297d749dd590f1d0340732e00d20e4af1b311df297df2a72cc79f0e4949e5ac00acb9dec29dcb50423facb2b3bcff6ad3d1d75350 WHIRLPOOL 7ed76fbb05f3c413d86f42b45ef73d5b333718031434273e512db43eae69900abfee7b10deff78f360131d50a1093e22786ca01b8eb5984ac5ac5330ba1f7eb1
+DIST Chameleon-2.19.tar.gz 202197 SHA256 744070535f8e85a277aef07b0a98256aec5bf6a0d9b909686ce571eb26914491 SHA512 7e90ccf5f53000b94452b8c343cf232d4bc48857dd33ea19bf44e6732033851459a0761cc0f2af5851b11f5c1cd698679ef541cbaa895373f59d66717b3fc267 WHIRLPOOL 6c24d006a707f2b3e2a0b2df5ee2fc52314a5c830fbb8096429ac40dc43e932ddcc38fbeef5886066f848f10076ea8a171a557f995c7b1df16bdf709a858ee4f
+DIST Chameleon-2.20.tar.gz 202396 SHA256 557deb604cc2fb235441f449f44feb3942258fcf233c7e75fcae6adeb886ced4 SHA512 805189e49c6b326f82ffaefdb1d734e3959167a0e3523531f9c9c554fc8412ab4ae401aacae023a3ba43d18019a6fccebafae87f2c6bed6c1c2f5b1aff080153 WHIRLPOOL 1c84afca8e7eb6231f9caea4934351d347bfc6cb52025754b197595eac368fb9e5a6ae9888809aca99f80ca8f0544e54426bc284a2314033b07771156011e597
+DIST Chameleon-2.22.tar.gz 201994 SHA256 6eef8c58d1c58b94f6502d4213c92b2037f5ab66386b3da5b117213faa0bf7f7 SHA512 f81b52a8463d1f4619580b2d51bb9e2f67bb752b95382d7ffd0357b9e2d05854ce6539a3e518ed32e6df4d35ee3d247771ff47d8039e2bdfc4c0a732fb7885c2 WHIRLPOOL 66a289cf0ae33fc9b5d935623ce7de3227582518918e420078436669c52660e0053a7ffb0f65dccde95203591ce4626e52c6d4a030650c83c6f48efaf9f5be69
diff --git a/dev-python/chameleon/chameleon-2.16.ebuild b/dev-python/chameleon/chameleon-2.16.ebuild
new file mode 100644
index 000000000000..fe675a2c5c33
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chameleon/chameleon-2.19.ebuild b/dev-python/chameleon/chameleon-2.19.ebuild
new file mode 100644
index 000000000000..e9f0c81c12c9
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.19.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chameleon/chameleon-2.20.ebuild b/dev-python/chameleon/chameleon-2.20.ebuild
new file mode 100644
index 000000000000..e9f0c81c12c9
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.20.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chameleon/chameleon-2.22.ebuild b/dev-python/chameleon/chameleon-2.22.ebuild
new file mode 100644
index 000000000000..e9f0c81c12c9
--- /dev/null
+++ b/dev-python/chameleon/chameleon-2.22.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Chameleon"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org http://pypi.python.org/pypi/Chameleon"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/chameleon/metadata.xml b/dev-python/chameleon/metadata.xml
new file mode 100644
index 000000000000..3469c1019df0
--- /dev/null
+++ b/dev-python/chameleon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Chameleon</remote-id>
+ </upstream>
+</pkgmetadata>