summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-03 11:09:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-03 11:13:39 -0800
commit74e52be3a78ff836c1aac0d296d00a93a901da6d (patch)
treec61d3d80dae3e362713340a6149f42c1425c57b6 /dev-python/characteristic/characteristic-14.3.0-r3.ebuild
parentapp-emulation/libvirt: Only require USE=cgroup-hybrid for USE=lxc (diff)
downloadgentoo-74e52be3a78ff836c1aac0d296d00a93a901da6d.tar.gz
gentoo-74e52be3a78ff836c1aac0d296d00a93a901da6d.tar.bz2
gentoo-74e52be3a78ff836c1aac0d296d00a93a901da6d.zip
dev-python/characteristic-14.3.0-r3: revbump, fix tests, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/characteristic/characteristic-14.3.0-r3.ebuild')
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/characteristic/characteristic-14.3.0-r3.ebuild b/dev-python/characteristic/characteristic-14.3.0-r3.ebuild
new file mode 100644
index 000000000000..65c57a80ce36
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.3.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}