summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-26 05:58:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-26 06:49:01 +0200
commitfb4a456f7b7d3136967352d50709acb58c4bb413 (patch)
treee9f3e0078dff9786e619cf9d2917684aa96e363f /dev-python/chardet
parentdev-python/virtualenv: Bump to 20.15.0 (diff)
downloadgentoo-fb4a456f7b7d3136967352d50709acb58c4bb413.tar.gz
gentoo-fb4a456f7b7d3136967352d50709acb58c4bb413.tar.bz2
gentoo-fb4a456f7b7d3136967352d50709acb58c4bb413.zip
dev-python/chardet: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest1
-rw-r--r--dev-python/chardet/chardet-5.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index ed73b3a9c79e..f983fed53661 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1 +1,2 @@
DIST chardet-4.0.0.tar.gz 1923933 BLAKE2B 10dce34cbe6f01536a526931510ed625bc5062335e9419e24c9e48d5697ebbe70dcc54ffaa976ec153340cc74c3086627a3b1dd9e34be32c89a9a81e83fd70d0 SHA512 cb0e052fdd9fec251ebc6eb3f31ca95ece017f2bfa99122997f989286988058ed9688e49d00631c63d8e4e52da1050e23f02b28d0e739aee7302b24c8808370e
+DIST chardet-5.0.0.tar.gz 2016879 BLAKE2B 006992a4945840b3720e93f932618cf81debc094a3ae353bfdd4e56ecdc5a01e4a250bed15473d8d59108978fdbfb769081a9b87f672d35f4892d5ba04c2deb5 SHA512 d19413a4f1f571f3627ec3f55dcc6a69497f6a1d72fe972051713f4d7a473cd539cfbce2eb2c7a070295aa640c6ac2aec6fc0064751e465311935c0e4d88061a
diff --git a/dev-python/chardet/chardet-5.0.0.ebuild b/dev-python/chardet/chardet-5.0.0.ebuild
new file mode 100644
index 000000000000..dbf91552b944
--- /dev/null
+++ b/dev-python/chardet/chardet-5.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="
+ https://github.com/chardet/chardet/
+ https://pypi.org/project/chardet/
+"
+SRC_URI="
+ https://github.com/chardet/chardet/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # super flaky test
+ # https://github.com/chardet/chardet/issues/256
+ test.py::test_detect_all_and_detect_one_should_agree
+)