summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-04 09:59:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-04 10:28:46 +0200
commite69b2883d62f46b9fa3ae225fe05481cd0a23728 (patch)
treedee0d8b2906812a5787955b01de3d21472889def /dev-python/cheroot/cheroot-8.5.2.ebuild
parentprofiles/package.mask: mask dev-ruby/{source_map,shotgun} for removal (diff)
downloadgentoo-e69b2883d62f46b9fa3ae225fe05481cd0a23728.tar.gz
gentoo-e69b2883d62f46b9fa3ae225fe05481cd0a23728.tar.bz2
gentoo-e69b2883d62f46b9fa3ae225fe05481cd0a23728.zip
dev-python/cheroot: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cheroot/cheroot-8.5.2.ebuild')
-rw-r--r--dev-python/cheroot/cheroot-8.5.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/cheroot/cheroot-8.5.2.ebuild b/dev-python/cheroot/cheroot-8.5.2.ebuild
index ad187eb5f9bd..7e8619853279 100644
--- a/dev-python/cheroot/cheroot-8.5.2.ebuild
+++ b/dev-python/cheroot/cheroot-8.5.2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+DESCRIPTION="High-performance, pure-Python HTTP server used by CherryPy"
HOMEPAGE="https://cherrypy.org/
https://pypi.org/project/cheroot/
https://github.com/cherrypy/cheroot/"
@@ -57,5 +56,5 @@ python_prepare_all() {
python_test() {
cd "${BUILD_DIR}" || die
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ epytest
}