summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-28 04:22:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-28 04:41:27 +0200
commit6a55eafcda92a3e6dba7d018b8753676f7b4af77 (patch)
tree7d66849db9919a9d18466c32c720d39688aa40b6 /dev-python/cheroot
parent*/*: Drop last-rited Py2 only pkgs (diff)
downloadgentoo-6a55eafcda92a3e6dba7d018b8753676f7b4af77.tar.gz
gentoo-6a55eafcda92a3e6dba7d018b8753676f7b4af77.tar.bz2
gentoo-6a55eafcda92a3e6dba7d018b8753676f7b4af77.zip
dev-python/cheroot: Bump to 8.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest1
-rw-r--r--dev-python/cheroot/cheroot-8.4.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index 8fcfcb69296a..7bc87abcab73 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -2,3 +2,4 @@ DIST cheroot-8.3.0.tar.gz 100557 BLAKE2B f5f2fd8a11a1a8660fc37030d501e93787be46d
DIST cheroot-8.3.1.tar.gz 104332 BLAKE2B ac79a5e84c534456067b83f11bd72cb34c0e3c850e49c69e0ff329cbe71fd4331397a38bc3b354529a8c4daea6e527733965ba8aafb33fb67e29e6a714b345cb SHA512 5aed493904d7e60118ae4b9498c10d48da553b3cbc1d713e3e870d771a7b669988d55bb0aa3223436cacdbc2249538be759a9145cf655603fbe5b88ee10e94dd
DIST cheroot-8.4.0.tar.gz 106091 BLAKE2B 4749e8dbbe3b368fb350ee11f1494919cae71b5d1dbda8ddee1b0ca812343c09d800646c0e757e0d1e711e486bd1985ba516a5f95541d56623ded78741e25d76 SHA512 b030cced23811659070dccacf3790288d4a0ba326b35a683c7eff9fd3902581f6afbf408315cef129187085c6adb2a813bc5d30cbaf56d2d00369b6e19336a37
DIST cheroot-8.4.1.tar.gz 107221 BLAKE2B cddfe305b472df4a20b5f93911a941c7d2f36dd5a7edfd593832d705b50aca2fa4bbac9f9e3a3b586623da2edafb115ebdf13b34ee3b284264ba6a31c544c8f8 SHA512 44ae1fc9a47160d3469ef1218dc60fc4c4bdb445c69b32d597fb6341b130ba36e9f04d2082e7218911ae07f4fa1a271526590db16840ff798a3788209498c10c
+DIST cheroot-8.4.2.tar.gz 107264 BLAKE2B d28d602ebd442ad5d85dfb2f4618b279e733cfca9d3c516ad1fbefcd318449155819549f6b929713d51d44fbaa9a7db383af81ea65271c6646a9245e521b3178 SHA512 d0b807969d491e0b3423453d27acfbe51147f6786c0b2c8a1b4774589e3e82b027277bf0ddd5ff406f31e0ac7d9dfbd6c2f02efe6911889986e72e9f16b8e62f
diff --git a/dev-python/cheroot/cheroot-8.4.2.ebuild b/dev-python/cheroot/cheroot-8.4.2.ebuild
new file mode 100644
index 000000000000..c66aaa7c635c
--- /dev/null
+++ b/dev-python/cheroot/cheroot-8.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="https://cherrypy.org/ https://pypi.org/project/Cheroot/ https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.11.0[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e '/setuptools_scm/d' -i setup.cfg || die
+ sed -e '/--cov/d' \
+ -e '/--testmon/d' \
+ -e '/--numproc/d' \
+ -i pytest.ini || die
+
+ # broken
+ sed -e '/False.*localhost/d' \
+ -i cheroot/test/test_ssl.py || die
+
+ distutils-r1_python_prepare_all
+}