summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-04-23 20:16:29 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-04-23 20:19:06 +0200
commit742ab7c142a65aeadb8514e8dfdeabfa162a9014 (patch)
tree06768a335c503dacaba4ef37882dbd11b4d860a0 /dev-python/chump/chump-1.6.0.ebuild
parentdev-libs/openssl: stable 1.1.1g for hppa, bug #717442 (diff)
downloadgentoo-742ab7c142a65aeadb8514e8dfdeabfa162a9014.tar.gz
gentoo-742ab7c142a65aeadb8514e8dfdeabfa162a9014.tar.bz2
gentoo-742ab7c142a65aeadb8514e8dfdeabfa162a9014.zip
dev-python/chump: add Python 3.8 support
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/chump/chump-1.6.0.ebuild')
-rw-r--r--dev-python/chump/chump-1.6.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/chump/chump-1.6.0.ebuild b/dev-python/chump/chump-1.6.0.ebuild
index 4eca65a67580..6ee3f01c296e 100644
--- a/dev-python/chump/chump-1.6.0.ebuild
+++ b/dev-python/chump/chump-1.6.0.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-# PyPy is not properly supported:
-# https://github.com/karanlyons/chump/issues/17
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
inherit distutils-r1
@@ -19,10 +17,11 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
+# The package has no test suite
+
python_prepare_all() {
sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
distutils-r1_python_prepare_all