summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 10:00:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 10:02:30 +0100
commit5ee97fb3041534b788833423778fa4cf491630a8 (patch)
tree7c6b747cc273405ceff5c63dfbb2e008e458ca3c /dev-python/clang-python/clang-python-13.0.0.9999.ebuild
parentsys-devel/clang: Add 13.x live ebuild (diff)
downloadgentoo-5ee97fb3041534b788833423778fa4cf491630a8.tar.gz
gentoo-5ee97fb3041534b788833423778fa4cf491630a8.tar.bz2
gentoo-5ee97fb3041534b788833423778fa4cf491630a8.zip
dev-python/clang-python: Add 13.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python/clang-python-13.0.0.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-13.0.0.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-13.0.0.9999.ebuild b/dev-python/clang-python/clang-python-13.0.0.9999.ebuild
new file mode 100644
index 000000000000..0e3b3ea06300
--- /dev/null
+++ b/dev-python/clang-python/clang-python-13.0.0.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}