summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-16 17:19:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 17:25:08 +0100
commit369a458303d9cecbe7636256218726cf0a3eecda (patch)
tree7cdc85e60697d19bb1be3da147634ec4a2a272cc /dev-python/clang-python/clang-python-19.0.0_pre20240316.ebuild
parentsys-devel/clang: Add 19.0.0_pre20240316 snapshot (diff)
downloadgentoo-369a458303d9cecbe7636256218726cf0a3eecda.tar.gz
gentoo-369a458303d9cecbe7636256218726cf0a3eecda.tar.bz2
gentoo-369a458303d9cecbe7636256218726cf0a3eecda.zip
dev-python/clang-python: Add 19.0.0_pre20240316 snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python/clang-python-19.0.0_pre20240316.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-19.0.0_pre20240316.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-19.0.0_pre20240316.ebuild b/dev-python/clang-python/clang-python-19.0.0_pre20240316.ebuild
new file mode 100644
index 000000000000..bef9bf6fddbd
--- /dev/null
+++ b/dev-python/clang-python/clang-python-19.0.0_pre20240316.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ test? (
+ sys-devel/clang:${LLVM_MAJOR}
+ )
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ # tests rely on results from a specific clang version, so override
+ # the search path
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
+ local -x CLANG_NO_DEFAULT_CONFIG=1
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}