summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-23 18:45:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-24 21:03:46 +0200
commit28e53e413e87497e26933afb058c3e6e7a79dcd6 (patch)
tree21b08888bd8a7092d0fe731d42987cbcf39c3a17 /dev-python/clang-python/clang-python-5.0.9999.ebuild
parentsys-devel/clang: Branch for 5.0.0 release (diff)
downloadgentoo-28e53e413e87497e26933afb058c3e6e7a79dcd6.tar.gz
gentoo-28e53e413e87497e26933afb058c3e6e7a79dcd6.tar.bz2
gentoo-28e53e413e87497e26933afb058c3e6e7a79dcd6.zip
dev-python/clang-python: Branch for 5.0.0 release
Diffstat (limited to 'dev-python/clang-python/clang-python-5.0.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-5.0.9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-5.0.9999.ebuild b/dev-python/clang-python/clang-python-5.0.9999.ebuild
new file mode 100644
index 000000000000..051a3308bd4d
--- /dev/null
+++ b/dev-python/clang-python/clang-python-5.0.9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_50"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${P}/bindings/python
+
+src_test() {
+ python_foreach_impl nosetests -v
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}