summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-12 20:18:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-12 20:20:55 +0100
commit186589b659839994a843f51ddaa66bbb0311301e (patch)
treef6ddfa8bd0ce1152008b4bfcb0f3e8d99e0eb728 /dev-python/click-help-colors
parentdev-python/voluptuous: Bump to 0.14.0 (diff)
downloadgentoo-186589b659839994a843f51ddaa66bbb0311301e.tar.gz
gentoo-186589b659839994a843f51ddaa66bbb0311301e.tar.bz2
gentoo-186589b659839994a843f51ddaa66bbb0311301e.zip
dev-python/click-help-colors: Bump to 0.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click-help-colors')
-rw-r--r--dev-python/click-help-colors/Manifest1
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
index 716f789af0a2..8a40debf3cb1 100644
--- a/dev-python/click-help-colors/Manifest
+++ b/dev-python/click-help-colors/Manifest
@@ -1 +1,2 @@
DIST click-help-colors-0.9.2.gh.tar.gz 130204 BLAKE2B ac8f4b0369f5a1d71115e92d84b6b2229f955c74d2ca443aa98319316d5a6d944d29ce4979fc2d8cd03dd5916c4ab6b0870172f2982a83df6d510e51b779ef60 SHA512 1092b256339faf7399274c7cd525895f53e57f31e5d0d4a7068e0fa29e7757d14881a2fd980c501a7277a25ece760623fa4c967c60302359c880899c8a01652f
+DIST click-help-colors-0.9.3.gh.tar.gz 131170 BLAKE2B 612789519501858ee8ed415b274b426273b6e4c48b9f650f966f0ee2774c97531c5bbbbf7e0e6edb08f50821635212a04f920a2a26d8897db9dd9413c3999bfd SHA512 7d3708ea710de41baca075468e5d434f5536d04ceb1092085c46cccc31f58d16f6ed1095efca1d9dc6bd1e5532a41e8bde4343d8197744fca58642dd80a03c59
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.3.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.3.ebuild
new file mode 100644
index 000000000000..1f2d4a2665be
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="
+ https://github.com/click-contrib/click-help-colors/
+ https://pypi.org/project/click-help-colors/
+"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}