summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-06-14 17:10:29 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-06-14 17:10:29 +0300
commitb86592f43f4e3e7436c1b307faeb21b21467a471 (patch)
tree40d8aecb1aa5a859cd22bc274c3073ce241257a2 /dev-python/click/click-5.1.ebuild
parentnet-p2p/qbittorrent: add myself as maintainer (diff)
downloadgentoo-b86592f43f4e3e7436c1b307faeb21b21467a471.tar.gz
gentoo-b86592f43f4e3e7436c1b307faeb21b21467a471.tar.bz2
gentoo-b86592f43f4e3e7436c1b307faeb21b21467a471.zip
dev-python/click: Add as dependency for platformio
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/click/click-5.1.ebuild')
-rw-r--r--dev-python/click/click-5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/click/click-5.1.ebuild b/dev-python/click/click-5.1.ebuild
new file mode 100644
index 000000000000..f6772af7b4c5
--- /dev/null
+++ b/dev-python/click/click-5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}