summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-24 09:44:03 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-24 09:44:07 +0100
commitde00f8e224cded2e844f11892a9eaea4c8251d33 (patch)
treee095256a9f3f514c54c364039f3d12eb86f02496 /dev-python/click/click-5.1.ebuild
parentdev-python/prompt_toolkit: Version Bump (diff)
downloadgentoo-de00f8e224cded2e844f11892a9eaea4c8251d33.tar.gz
gentoo-de00f8e224cded2e844f11892a9eaea4c8251d33.tar.bz2
gentoo-de00f8e224cded2e844f11892a9eaea4c8251d33.zip
dev-python/click: Build docs using python2
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=572660 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/click/click-5.1.ebuild')
-rw-r--r--dev-python/click/click-5.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/click/click-5.1.ebuild b/dev-python/click/click-5.1.ebuild
index 1cf3c66b6696..102ce0100b45 100644
--- a/dev-python/click/click-5.1.ebuild
+++ b/dev-python/click/click-5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,11 +17,17 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
IUSE="doc examples test"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die