summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-01 10:07:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-01 10:07:24 +0300
commit0f740649e06de3d7b326570dfbd4ad7a3be0a841 (patch)
treee7f3dbf76f428644d56ce9abfdb7bf4d65f19395 /dev-python/click
parentsys-devel/gcc: Stabilize 10.3.1_p20211126 ppc64, #833358 (diff)
downloadgentoo-0f740649e06de3d7b326570dfbd4ad7a3be0a841.tar.gz
gentoo-0f740649e06de3d7b326570dfbd4ad7a3be0a841.tar.bz2
gentoo-0f740649e06de3d7b326570dfbd4ad7a3be0a841.zip
dev-python/click: add 8.1.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index c84a740d1828..cb0bcdbd3f9f 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -2,3 +2,4 @@ DIST click-7.1.2.tar.gz 295757 BLAKE2B aea76d5378cfa49fe58a83132737d609d48b3d3a7
DIST click-8.0.4.tar.gz 332977 BLAKE2B 71366fa8436fb6997675ecb84d98f43b40a646466f0f9f7a51f145bd6a41950836df30a545e50ab6166f3643766c994f5a636b9a2b6e0a700eec04d377aced25 SHA512 2a572863814ef4f79ee408d4aa8df30a15b958986c4615e13bdeab30b4847679330e1b3baeeeff1aa80464a08418400c7a1ff22f29db4fc8d8042ab7b1ba475c
DIST click-8.1.0.tar.gz 333449 BLAKE2B c0f5dfb245c5c8a71e9aa5200393d021f4e77ae73fa9a8cdef4abc35546d2ff0b7b1322776002dc28b37e8311141fc3db8a39b5cfbb8947781326b6417494563 SHA512 7d9fcd74392baa55e0fd9050e7382d4b8b542856d4fee79ec5a4d6185ddeb47abaed1de6771e30aaec6cee5cff7166dd8ab7fefbc6aefa1856adc58b9fecc0c7
DIST click-8.1.1.tar.gz 333663 BLAKE2B c7b0de884c3ea5365d3227f5a4e81a41531dfa100705b203745bed15826cc7e9ace112c959ab5f4eabac510623d83ceeedf6ea36a40aaf8f997cbb6b3ba1abfb SHA512 b553d140f1425001575d7584367bd90cea6d20760b4a811efb0fb164f0d62d631f54514b033ceb1130d510f35cfb330f4af6d93d1e70dd1ea929b878304b9140
+DIST click-8.1.2.gh.tar.gz 333755 BLAKE2B cf579db101e296a0626445e0823d8c72bc6cd40f0ec667c3179465050d0aa7d7a94ed1416d583f7c9afde8e5ea41738c26b000f87c95074a9d93837c039d687a SHA512 8781965212a0732990e47050db8ae5e37633986b23cd7895d74f06007c61993f8ea45183376761987931caf00dd68c22900bc8d3930d4416853374cfd170a0e5
diff --git a/dev-python/click/click-8.1.2.ebuild b/dev-python/click/click-8.1.2.ebuild
new file mode 100644
index 000000000000..ba8f4b9c8fe8
--- /dev/null
+++ b/dev-python/click/click-8.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log_cabinet \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}