summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 20:32:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 20:48:38 +0200
commit5cba805a97a00647a1aff79f03d864ed393c6c51 (patch)
tree231238a5bdea322aa241b5c7c37a7ddb28dcc8dc /dev-python/click
parentdev-python/flask: Bump to 2.1.2 (diff)
downloadgentoo-5cba805a97a00647a1aff79f03d864ed393c6c51.tar.gz
gentoo-5cba805a97a00647a1aff79f03d864ed393c6c51.tar.bz2
gentoo-5cba805a97a00647a1aff79f03d864ed393c6c51.zip
dev-python/click: Bump to 8.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.1.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index cb0bcdbd3f9f..b5f1c1ff93b9 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -3,3 +3,4 @@ DIST click-8.0.4.tar.gz 332977 BLAKE2B 71366fa8436fb6997675ecb84d98f43b40a646466
DIST click-8.1.0.tar.gz 333449 BLAKE2B c0f5dfb245c5c8a71e9aa5200393d021f4e77ae73fa9a8cdef4abc35546d2ff0b7b1322776002dc28b37e8311141fc3db8a39b5cfbb8947781326b6417494563 SHA512 7d9fcd74392baa55e0fd9050e7382d4b8b542856d4fee79ec5a4d6185ddeb47abaed1de6771e30aaec6cee5cff7166dd8ab7fefbc6aefa1856adc58b9fecc0c7
DIST click-8.1.1.tar.gz 333663 BLAKE2B c7b0de884c3ea5365d3227f5a4e81a41531dfa100705b203745bed15826cc7e9ace112c959ab5f4eabac510623d83ceeedf6ea36a40aaf8f997cbb6b3ba1abfb SHA512 b553d140f1425001575d7584367bd90cea6d20760b4a811efb0fb164f0d62d631f54514b033ceb1130d510f35cfb330f4af6d93d1e70dd1ea929b878304b9140
DIST click-8.1.2.gh.tar.gz 333755 BLAKE2B cf579db101e296a0626445e0823d8c72bc6cd40f0ec667c3179465050d0aa7d7a94ed1416d583f7c9afde8e5ea41738c26b000f87c95074a9d93837c039d687a SHA512 8781965212a0732990e47050db8ae5e37633986b23cd7895d74f06007c61993f8ea45183376761987931caf00dd68c22900bc8d3930d4416853374cfd170a0e5
+DIST click-8.1.3.gh.tar.gz 333961 BLAKE2B ed80d9be1e5740f1e4af62e97cd78488dc99d59da4a6dc9c99fb62b08c32ca2b889e3678a2841052922d102d8ac83df19e3e2d0ff41c46387e695d3718c7702d SHA512 29194ee3877e013a2fe1037870522c5b5a78136ca60da9109f29312a3e52c767867f5eec2d90ca385cd0508f77555b9d6ad8f5141dc31900ddc9307a2207a818
diff --git a/dev-python/click/click-8.1.3.ebuild b/dev-python/click/click-8.1.3.ebuild
new file mode 100644
index 000000000000..4da31f5189e1
--- /dev/null
+++ b/dev-python/click/click-8.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://github.com/pallets/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log_cabinet \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}