summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-23 10:17:36 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-23 10:22:44 +0100
commit8c0a55578069ab0e9d8a6953350c799052e9c566 (patch)
tree0ff3b1b7e5714f91fd0e22916604361aacd7e717 /dev-python/click
parentdev-python/packaging: Version Bump (diff)
downloadgentoo-8c0a55578069ab0e9d8a6953350c799052e9c566.tar.gz
gentoo-8c0a55578069ab0e9d8a6953350c799052e9c566.tar.bz2
gentoo-8c0a55578069ab0e9d8a6953350c799052e9c566.zip
dev-python/click: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-6.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index ba2cf3057c7f..265666a9e3f6 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,3 +1,4 @@
DIST click-2.0.tar.gz 47342 SHA256 33a984fe73aa8c6bf69c38098b69dd38405529db54baf4c8cf64c50b2dee644f SHA512 4c703ab4b5c76e393420b0edf9af9e8ddb301ccfef5f8117d3408eaa8a94abe6b7b5c7a8b61b7774a3b459b153c10438e8934f21ceb73697199828cce2c2887c WHIRLPOOL bf599395245319b31c189df297a1ec35ca69723ed24e2d3e9aa9231a3cfebdb80e1f43a0b010865b6fbecf09f23dc1121cca232aec26f09bdb455f41da5261c4
DIST click-5.1.tar.gz 275592 SHA256 678c98275431fad324275dec63791e4a17558b40e5a110e20a82866139a85a5a SHA512 b860b0227644f5d1cc24d41e66985421ec971f11f3f596fb46508fdc787200b949e7ef29b2035421ebb0115384688da03c3c95a0d6acc58dd3b566b32a2b7c6a WHIRLPOOL 8bda8de886a272972595bf51af3881962063daaa4fc9e104af59b4798008a2f780c3fb4a758d7fe14ef075b92aecc43415b08bb213cbd6ac4ab92a56e405276e
DIST click-6.2.tar.gz 281717 SHA256 fba0ff70f5ebb4cebbf64c40a8fbc222fb7cf825237241e548354dabe3da6a82 SHA512 3950bd4e05823dbd526b3e3d17f9eb6871e1591342bdc4d21b7d4cea8f66791b1ab1d79ec664dae55cfbeaa5086fabb0db596bc88593251002c6584eae823477 WHIRLPOOL a53c5be5510e485f51682de0f13abadadc6627eda1ef0a9e55d2e7fe78a1fe79ba200c4172d47674d08d103b9b83dacb18da3ff8ddc09ad8e781503b87d5ceaf
+DIST click-6.3.tar.gz 283062 SHA256 b720d9faabe193287b71e3c26082b0f249501288e153b7e7cfce3bb87ac8cc1c SHA512 c7518b9c595fe35efb6be4391006a471cdc909f6725b9b3c45b06ec7b8b24560543ee151ff3afabc76ea23f4367795c4e5ace9b4b780c18c48a3e512474e3bf8 WHIRLPOOL 252ddf31265a2ed4eecc616ac94a7e0c32438c204729bff7e57b0ec850dd02004c76751934202f9de3bb4dc5811dfd10cb05f50d7e4a465dcc752438176c8ecc
diff --git a/dev-python/click/click-6.3.ebuild b/dev-python/click/click-6.3.ebuild
new file mode 100644
index 000000000000..6c9a3dcf7389
--- /dev/null
+++ b/dev-python/click/click-6.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}