summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 09:07:32 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 09:07:32 +0100
commitbc36914096a67a2449d3a215b42c24e899dc3f2f (patch)
treecd7304803c62fe5bc3ec6252fed5cb427b955e9c /dev-python/click
parentsys-kernel/aufs-sources: Bump to latest genpatches and linux release (diff)
downloadgentoo-bc36914096a67a2449d3a215b42c24e899dc3f2f.tar.gz
gentoo-bc36914096a67a2449d3a215b42c24e899dc3f2f.tar.bz2
gentoo-bc36914096a67a2449d3a215b42c24e899dc3f2f.zip
dev-python/click: Build docs using python2
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=572660 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/click-6.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/click/click-6.2.ebuild b/dev-python/click/click-6.2.ebuild
index b0aa96c7e1c2..59f7847ad9fb 100644
--- a/dev-python/click/click-6.2.ebuild
+++ b/dev-python/click/click-6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,11 +17,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="doc examples test"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die