summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 12:33:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 13:32:58 +0200
commitead510bbb5121b0fba3d1590bae1c879f33ac8c4 (patch)
tree0ac6510800862e76afaa6e1a64002ded6cbe37a0 /dev-python/click
parentdev-python/pybind11: Bump to 2.9.2 (diff)
downloadgentoo-ead510bbb5121b0fba3d1590bae1c879f33ac8c4.tar.gz
gentoo-ead510bbb5121b0fba3d1590bae1c879f33ac8c4.tar.bz2
gentoo-ead510bbb5121b0fba3d1590bae1c879f33ac8c4.zip
dev-python/click: Bump to 8.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-8.1.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index da9f8d2768e4..c84a740d1828 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,3 +1,4 @@
DIST click-7.1.2.tar.gz 295757 BLAKE2B aea76d5378cfa49fe58a83132737d609d48b3d3a71ec65c0a8a144c7a0e244b5bdf0196ffe2150889b82edda20c3f1faa3c84a227fc9ef459a5a9646cff86129 SHA512 d0caf2fb0a258774a18a7b8f83bdfa73abeb70196a70b45a6cc35befaeb862d068d2f2cce4e27201ab2e3adcd02e7e2f099d6c37c497a507010eefa10ad16eba
DIST click-8.0.4.tar.gz 332977 BLAKE2B 71366fa8436fb6997675ecb84d98f43b40a646466f0f9f7a51f145bd6a41950836df30a545e50ab6166f3643766c994f5a636b9a2b6e0a700eec04d377aced25 SHA512 2a572863814ef4f79ee408d4aa8df30a15b958986c4615e13bdeab30b4847679330e1b3baeeeff1aa80464a08418400c7a1ff22f29db4fc8d8042ab7b1ba475c
DIST click-8.1.0.tar.gz 333449 BLAKE2B c0f5dfb245c5c8a71e9aa5200393d021f4e77ae73fa9a8cdef4abc35546d2ff0b7b1322776002dc28b37e8311141fc3db8a39b5cfbb8947781326b6417494563 SHA512 7d9fcd74392baa55e0fd9050e7382d4b8b542856d4fee79ec5a4d6185ddeb47abaed1de6771e30aaec6cee5cff7166dd8ab7fefbc6aefa1856adc58b9fecc0c7
+DIST click-8.1.1.tar.gz 333663 BLAKE2B c7b0de884c3ea5365d3227f5a4e81a41531dfa100705b203745bed15826cc7e9ace112c959ab5f4eabac510623d83ceeedf6ea36a40aaf8f997cbb6b3ba1abfb SHA512 b553d140f1425001575d7584367bd90cea6d20760b4a811efb0fb164f0d62d631f54514b033ceb1130d510f35cfb330f4af6d93d1e70dd1ea929b878304b9140
diff --git a/dev-python/click/click-8.1.1.ebuild b/dev-python/click/click-8.1.1.ebuild
new file mode 100644
index 000000000000..88f5b3d0969b
--- /dev/null
+++ b/dev-python/click/click-8.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log_cabinet \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}