summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-02 11:44:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-02 11:47:59 -0500
commit43eb57ed35148e3355ad9bed5135ae54d174261f (patch)
tree0e94b3300408b88b6f5898291730b23b0ef61e3d /dev-python/cliff
parentdev-python/debtcollector: remove broken doc build (diff)
downloadgentoo-43eb57ed35148e3355ad9bed5135ae54d174261f.tar.gz
gentoo-43eb57ed35148e3355ad9bed5135ae54d174261f.tar.bz2
gentoo-43eb57ed35148e3355ad9bed5135ae54d174261f.zip
dev-python/cliff: remove broken doc build
Fixes: https://bugs.gentoo.org/696038 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-2.11.1.ebuild61
-rw-r--r--dev-python/cliff/cliff-2.12.0-r2.ebuild14
-rw-r--r--dev-python/cliff/cliff-2.12.0.ebuild14
4 files changed, 2 insertions, 88 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 9edbf1c4c3a6..9904d1a6e770 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,2 +1 @@
-DIST cliff-2.11.1.tar.gz 76570 BLAKE2B dc0b4a702c6807077f830941516e8c5f2dc6b732e7a7788eb2c2e5fc5c3fa8d893e7156d6ad76904deb2d1cf31d1ef50d08b73b750422b84bb053a09e4930bb2 SHA512 ba494cc26e103c6043de49a59b3e9c0c9bb1658416095f02c6bccd3536f24615239a66941fb971c289926c88e85eeb29eb10065379e4f21645828f6aa4a2755e
DIST cliff-2.12.0.tar.gz 77405 BLAKE2B 70b3865837bdba1396fd76b4937c594dfc9f50db24f684c6676c4ac1125ab34f6cdca29fe63a490d41abd49a268d6246afc873a5805446d06b07cd754aebb727 SHA512 5802cdd17b6aa81dbb344efb8ef53212de999ab33eaec1eb06e1d002ab513758d3634ae5013ece6375b1bb98c9fed99aa74cf92752c34e1132fa5ac20a969f4f
diff --git a/dev-python/cliff/cliff-2.11.1.ebuild b/dev-python/cliff/cliff-2.11.1.ebuild
deleted file mode 100644
index da502475db3d..000000000000
--- a/dev-python/cliff/cliff-2.11.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/openstack/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- )
-"
-# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
-RDEPEND="
- ${CDEPEND}
- >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
- "
-
-python_compile() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cliff/cliff-2.12.0-r2.ebuild b/dev-python/cliff/cliff-2.12.0-r2.ebuild
index 00c2e417af09..ac9f1fbe5384 100644
--- a/dev-python/cliff/cliff-2.12.0-r2.ebuild
+++ b/dev-python/cliff/cliff-2.12.0-r2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
@@ -32,9 +32,6 @@ DEPEND="
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
>=dev-python/stestr-2.1.0[${PYTHON_USEDEP}]
)
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- )
"
# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
RDEPEND="
@@ -49,17 +46,8 @@ RDEPEND="
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
"
-python_compile() {
- use doc && esetup.py build_sphinx
-}
-
python_test() {
stestr init || die "stestr init failed under ${EPYTHON}"
# needs outside access, so blacklist the test
virtx stestr run --black-regex cliff.tests.test_app.TestIO.test_writer_encoding || die "stestr run failed under ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/cliff/cliff-2.12.0.ebuild b/dev-python/cliff/cliff-2.12.0.ebuild
index 9a870593d9ab..5471b0269370 100644
--- a/dev-python/cliff/cliff-2.12.0.ebuild
+++ b/dev-python/cliff/cliff-2.12.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64 hppa ~mips s390 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
@@ -30,9 +30,6 @@ DEPEND="
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
)
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- )
"
# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
RDEPEND="
@@ -47,15 +44,6 @@ RDEPEND="
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
"
-python_compile() {
- use doc && esetup.py build_sphinx
-}
-
python_test() {
nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}