summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 15:43:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 15:56:08 +0200
commit5e2bff549ec69b8d2554afd52a32eed8bf7fce7a (patch)
treee09a0545e5f52937ae82984f88541726d8c6c1a2 /dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
parentapp-i18n/yaskkserv2: drop old (diff)
downloadgentoo-5e2bff549ec69b8d2554afd52a32eed8bf7fce7a.tar.gz
gentoo-5e2bff549ec69b8d2554afd52a32eed8bf7fce7a.tar.bz2
gentoo-5e2bff549ec69b8d2554afd52a32eed8bf7fce7a.zip
dev-python/cloudpickle: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cloudpickle/cloudpickle-3.0.0.ebuild')
-rw-r--r--dev-python/cloudpickle/cloudpickle-3.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild b/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
new file mode 100644
index 000000000000..a6afca0f935c
--- /dev/null
+++ b/dev-python/cloudpickle/cloudpickle-3.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extended pickling support for Python objects"
+HOMEPAGE="
+ https://github.com/cloudpipe/cloudpickle/
+ https://pypi.org/project/cloudpickle/
+"
+SRC_URI="
+ https://github.com/cloudpipe/cloudpickle/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH=${PYTHONPATH}:tests/cloudpickle_testpkg
+ # -s unbreaks some tests
+ # https://github.com/cloudpipe/cloudpickle/issues/252
+ epytest -s
+}