summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-26 21:09:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-26 21:09:14 +0300
commit11079947cea00a2323ac06bcb57aa6df3e4c4e98 (patch)
tree3a1e41e01c21139b9f20e581ed14af4a19a08e4a /dev-python/cmd2
parentdev-python/click: drop 8.0.3 (diff)
downloadgentoo-11079947cea00a2323ac06bcb57aa6df3e4c4e98.tar.gz
gentoo-11079947cea00a2323ac06bcb57aa6df3e4c4e98.tar.bz2
gentoo-11079947cea00a2323ac06bcb57aa6df3e4c4e98.zip
dev-python/cmd2: drop 2.3.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-2.3.3.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 614972e417b5..eef60eddc678 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,2 +1 @@
-DIST cmd2-2.3.3.tar.gz 675880 BLAKE2B 216b10d7a1d2eb78106e5af51a6c996ea22ff8ef13503ace6019978152f63d5015e61ab911a839703d2b3506fea4e709d507d147b2af259cf933ad628e52be22 SHA512 30d7a82a1c3d23431a40a7e99f10a4c23227e9ab073ab1d7fd83e516f54e9c90bda10e6072b50c0a2ca435498c1060e06b32a550409721899e28d2662995a8b8
DIST cmd2-2.4.0.tar.gz 680118 BLAKE2B 09f4893db7587dce9fd59103f8a1ef54c2b61248dd4aed313a90a390bb50e8927ef7a11dc5ca3af90b5ccf36ce16e0e18f3b555cc961a8c6862f7b8131f190ae SHA512 4ecd4c71294bee86f02b39a588c42a7232309db54459c950f77734926dedc3ec273237b9615bab6ef8a499c65442e3d6f7d2e9f159ccca021db0b450435ffbc0
diff --git a/dev-python/cmd2/cmd2-2.3.3.ebuild b/dev-python/cmd2/cmd2-2.3.3.ebuild
deleted file mode 100644
index 6603d301f98e..000000000000
--- a/dev-python/cmd2/cmd2-2.3.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="https://github.com/python-cmd2/cmd2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
-"
-# pyperclip uses clipboard backends in the following preference order:
-# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
-# klipper is known to be broken in Xvfb, and therefore causes test
-# failures. to avoid them, we must ensure that one of the backends
-# preferred to it is available (i.e. xclip or xsel) + which(1).
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- sys-apps/which
- || (
- x11-misc/xclip
- x11-misc/xsel
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e '/--cov/d' setup.cfg || die
-}
-
-src_test() {
- # tests rely on very specific text wrapping...
- local -x COLUMNS=80
- virtx distutils-r1_src_test
-}