summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-13 12:21:17 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-13 15:05:28 +0100
commitc0b8961075092ce40bc7eb0879d4c8f4c1b58cae (patch)
treedee0d0edc49ea4048f5962e061cc15292f7f1fb7 /dev-python/colorama/colorama-0.3.5.ebuild
parentdev-python/decorator: Version Bump (diff)
downloadgentoo-c0b8961075092ce40bc7eb0879d4c8f4c1b58cae.tar.gz
gentoo-c0b8961075092ce40bc7eb0879d4c8f4c1b58cae.tar.bz2
gentoo-c0b8961075092ce40bc7eb0879d4c8f4c1b58cae.zip
dev-python/colorama: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/colorama/colorama-0.3.5.ebuild')
-rw-r--r--dev-python/colorama/colorama-0.3.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/colorama/colorama-0.3.5.ebuild b/dev-python/colorama/colorama-0.3.5.ebuild
new file mode 100644
index 000000000000..9ce4094085d6
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://code.google.com/p/colorama/
+ https://pypi.python.org/pypi/colorama
+ https://github.com/tartley/colorama"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demos/. )
+ distutils-r1_python_install_all
+}