summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-08 19:22:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-08 19:22:26 +0100
commit10f462be656df85eebfde36ccf2fcaaac0cd7c99 (patch)
treef29e96180764f20cc1926e046a83378d08cbe62e /dev-python/colorclass
parentdev-python/distlib: Remove old (diff)
downloadgentoo-10f462be656df85eebfde36ccf2fcaaac0cd7c99.tar.gz
gentoo-10f462be656df85eebfde36ccf2fcaaac0cd7c99.tar.bz2
gentoo-10f462be656df85eebfde36ccf2fcaaac0cd7c99.zip
dev-python/colorclass: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/colorclass')
-rw-r--r--dev-python/colorclass/Manifest1
-rw-r--r--dev-python/colorclass/colorclass-2.2.0-r1.ebuild22
-rw-r--r--dev-python/colorclass/files/colorclass-2.2.0-fix-py3.10.patch28
-rw-r--r--dev-python/colorclass/files/colorclass-2.2.0-tests.patch12
4 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/colorclass/Manifest b/dev-python/colorclass/Manifest
index a1c3916f4544..a72fca89d8ca 100644
--- a/dev-python/colorclass/Manifest
+++ b/dev-python/colorclass/Manifest
@@ -1,2 +1 @@
-DIST colorclass-2.2.0.gh.tar.gz 486151 BLAKE2B d8f4c9e826cf284df47bf2aac4da71f448818858e2383b331b5bba791d9db3c5c11d5aff74b3eb740e657914137b2b74b217854ab589806a22a0ff6697cbde1c SHA512 c627cdf6abdb5a60e9ecc1fb3b669898edc027fdc3f8cde31be2e10402ee308c2067fcd50d1228759e93fc58c521b7fc12e6b259233a17cf99f55cda26279fed
DIST colorclass-2.2.2.gh.tar.gz 490884 BLAKE2B e03c1a7091c133cea67c595363029121083d9a9d70a27f5803b20bb810b105ea9cb95aa68114ba98526b8a3b0e8365eadd7b375443215a5e0b636f0bd4cce632 SHA512 c38b58d4122e794654a8ac71adb2be0fb679eb10bd70c9d8f5dee06b3c978c1530bb3fb8fd6530d88aa35311a46a2590b709e4dcc6e3a81d14b90bf8cb74ebc1
diff --git a/dev-python/colorclass/colorclass-2.2.0-r1.ebuild b/dev-python/colorclass/colorclass-2.2.0-r1.ebuild
deleted file mode 100644
index fde6c8c536af..000000000000
--- a/dev-python/colorclass/colorclass-2.2.0-r1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Colorful worry-free console applications for multiple platforms"
-HOMEPAGE="https://pypi.org/project/colorclass/ https://github.com/Robpol86/colorclass"
-SRC_URI="https://github.com/Robpol86/colorclass/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-PATCHES=(
- "${FILESDIR}/${P}-tests.patch"
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/colorclass/files/colorclass-2.2.0-fix-py3.10.patch b/dev-python/colorclass/files/colorclass-2.2.0-fix-py3.10.patch
deleted file mode 100644
index ee67d6d40bb3..000000000000
--- a/dev-python/colorclass/files/colorclass-2.2.0-fix-py3.10.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From f8bbe9fdcff1d97b1d0e5dcb94680923cc43a507 Mon Sep 17 00:00:00 2001
-From: Ralph Broenink <ralph@ralphbroenink.net>
-Date: Mon, 24 Aug 2020 14:49:24 +0200
-Subject: [PATCH] Make code forwards-compatible with Python 3.9
-
-Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated since Python 3.3, and in 3.9 it will stop working
----
- colorclass/codes.py | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/colorclass/codes.py b/colorclass/codes.py
-index b0ecb03..8b6085d 100644
---- a/colorclass/codes.py
-+++ b/colorclass/codes.py
-@@ -1,7 +1,12 @@
- """Handles mapping between color names and ANSI codes and determining auto color codes."""
-
- import sys
--from collections import Mapping
-+try:
-+ # Using or importing the ABCs from 'collections' instead of from 'collections.abc' is
-+ # deprecated since Python 3.3, and in 3.9 it will stop working
-+ from collections.abc import Mapping
-+except ImportError:
-+ from collections import Mapping
-
- BASE_CODES = {
- '/all': 0, 'b': 1, 'f': 2, 'i': 3, 'u': 4, 'flash': 5, 'outline': 6, 'negative': 7, 'invis': 8, 'strike': 9,
diff --git a/dev-python/colorclass/files/colorclass-2.2.0-tests.patch b/dev-python/colorclass/files/colorclass-2.2.0-tests.patch
deleted file mode 100644
index f25dd0440aa7..000000000000
--- a/dev-python/colorclass/files/colorclass-2.2.0-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/tests/test_example.py b/tests/test_example.py
-index 7ee8c05..3516460 100644
---- a/tests/test_example.py
-+++ b/tests/test_example.py
-@@ -10,6 +10,7 @@ from tests.conftest import PROJECT_ROOT
- from tests.screenshot import RunNewConsole, screenshot_until_match
-
-
-+@pytest.mark.skip(reason="test fails on all platforms")
- @pytest.mark.parametrize('colors', [True, False, None])
- @pytest.mark.parametrize('light_bg', [True, False, None])
- def test_piped(colors, light_bg):