summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 22:49:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 22:52:59 +0100
commitdff5c63b165fc25ee4388dd64f0e887aa6ca1b08 (patch)
tree03162cd46f9d2b50a7e2bc1bc30fcef3985ee494 /dev-python/colorclass
parentdev-python/poetry-core: Add pypy3 love (diff)
downloadgentoo-dff5c63b165fc25ee4388dd64f0e887aa6ca1b08.tar.gz
gentoo-dff5c63b165fc25ee4388dd64f0e887aa6ca1b08.tar.bz2
gentoo-dff5c63b165fc25ee4388dd64f0e887aa6ca1b08.zip
dev-python/colorclass: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/colorclass')
-rw-r--r--dev-python/colorclass/colorclass-2.2.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/colorclass/colorclass-2.2.2-r1.ebuild b/dev-python/colorclass/colorclass-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..8c190ca0cc51
--- /dev/null
+++ b/dev-python/colorclass/colorclass-2.2.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorful worry-free console applications for multiple platforms"
+HOMEPAGE="
+ https://pypi.org/project/colorclass/
+ https://github.com/matthewdeanmartin/colorclass"
+SRC_URI="
+ https://github.com/matthewdeanmartin/colorclass/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/docopt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/requires/s:poetry:&-core:' \
+ -e '/backend/s:poetry:&.core:' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}