summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-29 10:45:42 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-29 19:49:14 +0100
commite06343dfcd25aebe6533f812e4caa0c8f1a37bfb (patch)
tree1f95bc38c98ad122d7d24ba9b9fbab0bce76c257 /dev-python/coloredlogs/coloredlogs-6.1.ebuild
parentdev-python/capturer: Version Bump and Py3.6 support (diff)
downloadgentoo-e06343dfcd25aebe6533f812e4caa0c8f1a37bfb.tar.gz
gentoo-e06343dfcd25aebe6533f812e4caa0c8f1a37bfb.tar.bz2
gentoo-e06343dfcd25aebe6533f812e4caa0c8f1a37bfb.zip
dev-python/coloredlogs: Version Bump and Py3.6 support
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/coloredlogs/coloredlogs-6.1.ebuild')
-rw-r--r--dev-python/coloredlogs/coloredlogs-6.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/coloredlogs-6.1.ebuild b/dev-python/coloredlogs/coloredlogs-6.1.ebuild
new file mode 100644
index 000000000000..49ae56fe7514
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.python.org/pypi/coloredlogs
+ https://github.com/xolox/python-coloredlogs
+ http://coloredlogs.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/humanfriendly-2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/capturer-2.2[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/verboselogs-1.5[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( README.rst )
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-skip-cli-test.patch )
+
+python_test() {
+ # Sandbox violations
+ sed \
+ -e 's:test_system_logging:_&:g' \
+ -e 's:test_syslog_shortcut_simple:_&:g' \
+ -e 's:test_syslog_shortcut_enhanced:_&:g' \
+ -i ${PN}/tests.py || die
+ esetup.py test
+}