summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-12 08:12:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-12 08:39:06 +0200
commitbc667cdf16fc0f38395f9168b4942449698f6938 (patch)
tree4adbd5b18e3202de3f6785ce5f1c0732b7ba0b81 /dev-python/coloredlogs
parentapp-admin/awscli: Bump to 1.19.93 (diff)
downloadgentoo-bc667cdf16fc0f38395f9168b4942449698f6938.tar.gz
gentoo-bc667cdf16fc0f38395f9168b4942449698f6938.tar.bz2
gentoo-bc667cdf16fc0f38395f9168b4942449698f6938.zip
dev-python/coloredlogs: Bump to 15.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coloredlogs')
-rw-r--r--dev-python/coloredlogs/Manifest1
-rw-r--r--dev-python/coloredlogs/coloredlogs-15.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/Manifest b/dev-python/coloredlogs/Manifest
index 33c860803bc3..b338c23d8ef1 100644
--- a/dev-python/coloredlogs/Manifest
+++ b/dev-python/coloredlogs/Manifest
@@ -1 +1,2 @@
DIST coloredlogs-14.0.tar.gz 275863 BLAKE2B 0a8c026220955397378ad2b43a69c89c5710a09e2d9ed81a3f25408c60e171f4b8f78239696a0bc1b51fc3dd9bfca80df63e1f1d7afb6bee0046209a089e0d6d SHA512 3434a95f3216d19af5d7a48324e5afd5e975f92d9f6b99f40df2c0a635f1738e0bc6d7277a549a42a0fec5a8601f82908c4b0205ceeb3666f49210f66fe58671
+DIST coloredlogs-15.0.1.tar.gz 278520 BLAKE2B 446aea9adfc8a1ea7f2e5b4a0279d124a3e174feec4a6d9346059fa00fbcb2717d6480392051cc44f0c1f66e022cfc03238acae59b9496e9f70695d99143dfd6 SHA512 577af26af8d27bca3f10e6aaa257245aba608cc3832985ba57bcb2b590b10bf054796a2210749c15ee1b1a17623e007e4ac3ba17bed6af95544f85f5dfafaf21
diff --git a/dev-python/coloredlogs/coloredlogs-15.0.1.ebuild b/dev-python/coloredlogs/coloredlogs-15.0.1.ebuild
new file mode 100644
index 000000000000..806bf1c5c1a7
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-15.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/humanfriendly-9.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/coloredlogs-14.0-fix-install-prefix.patch" )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # test_cli_conversion requires the package to be installed
+ distutils_install_for_testing
+ # test_auto_install fails because the pth file isn't being loaded
+ epytest coloredlogs/tests.py \
+ --deselect coloredlogs/tests.py::ColoredLogsTestCase::test_auto_install
+}