summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:34:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:24 +0100
commit21f448a31678bb4610f94a5e9a9033add8d53388 (patch)
treed85c5426f47d3e790b33db688a17a5bf241aed71 /dev-python/comm/comm-0.1.3.ebuild
parentdev-python/accessible-pygments: Bump to 0.0.4 (diff)
downloadgentoo-21f448a31678bb4610f94a5e9a9033add8d53388.tar.gz
gentoo-21f448a31678bb4610f94a5e9a9033add8d53388.tar.bz2
gentoo-21f448a31678bb4610f94a5e9a9033add8d53388.zip
dev-python/comm: Bump to 0.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/comm/comm-0.1.3.ebuild')
-rw-r--r--dev-python/comm/comm-0.1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/comm/comm-0.1.3.ebuild b/dev-python/comm/comm-0.1.3.ebuild
new file mode 100644
index 000000000000..872e77ab10f3
--- /dev/null
+++ b/dev-python/comm/comm-0.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest