summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-12-17 19:46:34 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-12-29 00:01:12 +0100
commitfae66b58c11fd40a8c906ebe752b9bda75fa0f3e (patch)
treefac2f605a0bbfc7bf8672dfa29043478a5a3552f /dev-python/configargparse/configargparse-0.13.0.ebuild
parentapp-benchmarks/geekbench: drop old version. (diff)
downloadgentoo-fae66b58c11fd40a8c906ebe752b9bda75fa0f3e.tar.gz
gentoo-fae66b58c11fd40a8c906ebe752b9bda75fa0f3e.tar.bz2
gentoo-fae66b58c11fd40a8c906ebe752b9bda75fa0f3e.zip
dev-python/configargparse: bump to version 0.13.0.
Also added python3.7 support. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/10653 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/configargparse/configargparse-0.13.0.ebuild')
-rw-r--r--dev-python/configargparse/configargparse-0.13.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/configargparse/configargparse-0.13.0.ebuild b/dev-python/configargparse/configargparse-0.13.0.ebuild
new file mode 100644
index 000000000000..330c7b97b519
--- /dev/null
+++ b/dev-python/configargparse/configargparse-0.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="ConfigArgParse"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="https://github.com/zorro3/ConfigArgParse https://pypi.org/project/ConfigArgParse/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" tests/test_configargparse.py || die
+}