summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 22:26:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-02 23:01:36 +0200
commit0e80bc48cac3883bd642fdf639aec2c616671248 (patch)
tree79cabd17c5fee8b56c8263f26d9da0d70eae411e /dev-python/configargparse/configargparse-1.5.1.ebuild
parentdev-python/python-xlib: Bump to 0.31 (diff)
downloadgentoo-0e80bc48cac3883bd642fdf639aec2c616671248.tar.gz
gentoo-0e80bc48cac3883bd642fdf639aec2c616671248.tar.bz2
gentoo-0e80bc48cac3883bd642fdf639aec2c616671248.zip
dev-python/configargparse: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configargparse/configargparse-1.5.1.ebuild')
-rw-r--r--dev-python/configargparse/configargparse-1.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/configargparse/configargparse-1.5.1.ebuild b/dev-python/configargparse/configargparse-1.5.1.ebuild
new file mode 100644
index 000000000000..4dd20030e229
--- /dev/null
+++ b/dev-python/configargparse/configargparse-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="ConfigArgParse"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="
+ https://github.com/bw2/ConfigArgParse/
+ https://pypi.org/project/ConfigArgParse/"
+SRC_URI="
+ https://github.com/bw2/ConfigArgParse/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}