summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-19 06:17:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-19 07:08:16 +0100
commit8698b2f661bfdce95722176adf5ad8ac5506e2fc (patch)
tree09704a05c7df407d57c76374ce45f91e9ce03cd9 /dev-python/configobj
parentdev-python/tempora: Bump to 5.2.1 (diff)
downloadgentoo-8698b2f661bfdce95722176adf5ad8ac5506e2fc.tar.gz
gentoo-8698b2f661bfdce95722176adf5ad8ac5506e2fc.tar.bz2
gentoo-8698b2f661bfdce95722176adf5ad8ac5506e2fc.zip
dev-python/configobj: Bump to 5.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configobj')
-rw-r--r--dev-python/configobj/Manifest1
-rw-r--r--dev-python/configobj/configobj-5.0.8.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/configobj/Manifest b/dev-python/configobj/Manifest
index 2c530d3e8d16..a66999359b64 100644
--- a/dev-python/configobj/Manifest
+++ b/dev-python/configobj/Manifest
@@ -1 +1,2 @@
DIST configobj-5.0.6.gh.tar.gz 143664 BLAKE2B b554d0aec903aecb55387a0164cd6f8d442e9fc1ab231ce7f7123e7a5041e07a86f5f7bf70492ca93fcdc1bd3caa5b855c427f060842e3b4a7524afbcc417a76 SHA512 326eb86e362f281ebf07abcb1cf7616abb270c482eafe842371cda8708245ca5e8262f1644b7164664ecc10e9004ed061c9de18cd233a657d4697dbc3ba3c59d
+DIST configobj-5.0.8.gh.tar.gz 99071 BLAKE2B 61fb8622f3771f56f3a67511ce0eee11b9022a47a6a48858fafad966dd7fb18387d18dc0c32984bec064c2b03a7c72570248a967bf428f871c5b8ba4353a71e7 SHA512 26cdfec9f4d7adbab579191b29e6642f4f2a6fc73353f877565b76682d6087748f466f9cbb82fccfb2d409bace29c377c2276848179f5cb396e6ff1375c8edf2
diff --git a/dev-python/configobj/configobj-5.0.8.ebuild b/dev-python/configobj/configobj-5.0.8.ebuild
new file mode 100644
index 000000000000..fbc9ac3cae0a
--- /dev/null
+++ b/dev-python/configobj/configobj-5.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="
+ https://github.com/DiffSK/configobj/
+ https://pypi.org/project/configobj/
+"
+SRC_URI="
+ https://github.com/DiffSK/configobj/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest