summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 08:46:06 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 08:50:40 +0100
commitf4f0202193e0962c058300d7fc5419899d829e15 (patch)
tree50fe47ccc2eca4dab24d4ffc8feb9d7335af967e /dev-python/configobj
parentdev-python/paramiko: Remove old (diff)
downloadgentoo-f4f0202193e0962c058300d7fc5419899d829e15.tar.gz
gentoo-f4f0202193e0962c058300d7fc5419899d829e15.tar.bz2
gentoo-f4f0202193e0962c058300d7fc5419899d829e15.zip
dev-python/configobj: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configobj')
-rw-r--r--dev-python/configobj/Manifest1
-rw-r--r--dev-python/configobj/configobj-5.0.6-r2.ebuild23
-rw-r--r--dev-python/configobj/files/configobj-5.0.6-fix-py2-tests.patch40
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/configobj/Manifest b/dev-python/configobj/Manifest
index a66999359b64..737c0496a495 100644
--- a/dev-python/configobj/Manifest
+++ b/dev-python/configobj/Manifest
@@ -1,2 +1 @@
-DIST configobj-5.0.6.gh.tar.gz 143664 BLAKE2B b554d0aec903aecb55387a0164cd6f8d442e9fc1ab231ce7f7123e7a5041e07a86f5f7bf70492ca93fcdc1bd3caa5b855c427f060842e3b4a7524afbcc417a76 SHA512 326eb86e362f281ebf07abcb1cf7616abb270c482eafe842371cda8708245ca5e8262f1644b7164664ecc10e9004ed061c9de18cd233a657d4697dbc3ba3c59d
DIST configobj-5.0.8.gh.tar.gz 99071 BLAKE2B 61fb8622f3771f56f3a67511ce0eee11b9022a47a6a48858fafad966dd7fb18387d18dc0c32984bec064c2b03a7c72570248a967bf428f871c5b8ba4353a71e7 SHA512 26cdfec9f4d7adbab579191b29e6642f4f2a6fc73353f877565b76682d6087748f466f9cbb82fccfb2d409bace29c377c2276848179f5cb396e6ff1375c8edf2
diff --git a/dev-python/configobj/configobj-5.0.6-r2.ebuild b/dev-python/configobj/configobj-5.0.6-r2.ebuild
deleted file mode 100644
index 944ed672f97a..000000000000
--- a/dev-python/configobj/configobj-5.0.6-r2.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple config file reader and writer"
-HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html https://pypi.org/project/configobj/"
-SRC_URI="https://github.com/DiffSK/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}/${P}-fix-py2-tests.patch" )
-
-distutils_enable_tests pytest
diff --git a/dev-python/configobj/files/configobj-5.0.6-fix-py2-tests.patch b/dev-python/configobj/files/configobj-5.0.6-fix-py2-tests.patch
deleted file mode 100644
index 49576b4f43e7..000000000000
--- a/dev-python/configobj/files/configobj-5.0.6-fix-py2-tests.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/tests/test_validate.py b/tests/test_validate.py
-index bffb0dc..c7d57d3 100644
---- a/tests/test_validate.py
-+++ b/tests/test_validate.py
-@@ -2,7 +2,7 @@
-
- from configobj import ConfigObj
- import pytest
--from validate import Validator, VdtValueTooSmallError
-+from validate import Validator, VdtValueTooSmallError, dottedQuadToNum
-
-
- class TestBasic(object):
-@@ -161,3 +161,26 @@ class TestBasic(object):
- 'test3': 3,
- 'test4': 6.0
- }}}
-+
-+
-+class TestDottedQuadToNum(object):
-+
-+ def test_stripped(self):
-+ assert dottedQuadToNum('192.0.2.0') == 3221225984
-+ assert dottedQuadToNum('192.0.2.1 ') == 3221225985
-+ assert dottedQuadToNum(' 192.0.2.2') == 3221225986
-+ assert dottedQuadToNum('\t\t192.0.2.3\n') == 3221225987
-+ with pytest.raises(ValueError) as excinfo:
-+ dottedQuadToNum('192. 0. 2. 4')
-+ assert str(excinfo.value) == 'Not a good dotted-quad IP: 192. 0. 2. 4'
-+
-+ def test_boundaries(self):
-+ assert dottedQuadToNum('0.0.0.0') == 0
-+ assert dottedQuadToNum('255.255.255.255') == 4294967295
-+ with pytest.raises(ValueError) as excinfo:
-+ dottedQuadToNum('255.255.255.256')
-+ assert str(excinfo.value) == (
-+ 'Not a good dotted-quad IP: 255.255.255.256')
-+ with pytest.raises(ValueError) as excinfo:
-+ dottedQuadToNum('-1')
-+ assert str(excinfo.value) == 'Not a good dotted-quad IP: -1'