summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2016-08-06 23:35:19 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-02 19:18:14 +0200
commit91c059a0c8b7996e23979083ec20e6345c59c03e (patch)
tree6b5a024c15c812c25a9110c1009f0d97d6995947 /dev-python/configshell/configshell-1.6.ebuild
parentsys-block/targetcli: update live ebuild (diff)
downloadgentoo-91c059a0c8b7996e23979083ec20e6345c59c03e.tar.gz
gentoo-91c059a0c8b7996e23979083ec20e6345c59c03e.tar.bz2
gentoo-91c059a0c8b7996e23979083ec20e6345c59c03e.zip
dev-python/configshell: add version 1.6
Gentoo-Bug: https://bugs.gentoo.org/453270 Reported-by: Andrew Hamilton <andrew@ahamilto.net> Closes: https://github.com/gentoo/gentoo/pull/2034 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/configshell/configshell-1.6.ebuild')
-rw-r--r--dev-python/configshell/configshell-1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/configshell/configshell-1.6.ebuild b/dev-python/configshell/configshell-1.6.ebuild
new file mode 100644
index 000000000000..dbc88ecbdaeb
--- /dev/null
+++ b/dev-python/configshell/configshell-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="ConfigShell Community Edition for target_core_mod/ConfigFS"
+HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/Datera/${PN}.git
+ https://github.com/Datera/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Datera/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="dev-python/epydoc[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/urwid[${PYTHON_USEDEP}]"