summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-12 12:04:09 +0200
committerDavid Seifert <soap@gentoo.org>2019-09-12 12:04:09 +0200
commite13ecfddda536fbbe4b127a60c496eea7cbcfae6 (patch)
tree6827d5e95e62ecbc6f5723c6cf713c2a9bad978c /dev-python/confuse/confuse-1.0.0.ebuild
parentx11-drivers/nvidia-drivers: Old (diff)
downloadgentoo-e13ecfddda536fbbe4b127a60c496eea7cbcfae6.tar.gz
gentoo-e13ecfddda536fbbe4b127a60c496eea7cbcfae6.tar.bz2
gentoo-e13ecfddda536fbbe4b127a60c496eea7cbcfae6.zip
dev-python/confuse: new package (1.0.0)
Confuse is a configuration library for Python that uses YAML. Closes: https://bugs.gentoo.org/693178 Closes: https://github.com/gentoo/gentoo/pull/12828 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/confuse/confuse-1.0.0.ebuild')
-rw-r--r--dev-python/confuse/confuse-1.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/confuse/confuse-1.0.0.ebuild b/dev-python/confuse/confuse-1.0.0.ebuild
new file mode 100644
index 000000000000..716e4d492632
--- /dev/null
+++ b/dev-python/confuse/confuse-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="https://github.com/beetbox/confuse"
+SRC_URI="https://github.com/beetbox/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ rm -r docs/_build/html/_sources || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "Tests failed"
+ if use doc; then
+ sphinx-build -W -q -b html docs __doctest || die "Doc tests failed"
+ fi
+}