summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-11-24 15:59:48 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-25 10:55:08 +0200
commit5efcfacec710e11dbb6681548c3d6d720e5b4974 (patch)
tree9eb5764815ba9edf6878ed055a0381d179724800 /dev-python/confuse/confuse-1.4.0.ebuild
parentdev-python/python-heatclient: Remove old (diff)
downloadgentoo-5efcfacec710e11dbb6681548c3d6d720e5b4974.tar.gz
gentoo-5efcfacec710e11dbb6681548c3d6d720e5b4974.tar.bz2
gentoo-5efcfacec710e11dbb6681548c3d6d720e5b4974.zip
dev-python/confuse: verbump to 1.4.0
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18388 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/confuse/confuse-1.4.0.ebuild')
-rw-r--r--dev-python/confuse/confuse-1.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/confuse/confuse-1.4.0.ebuild b/dev-python/confuse/confuse-1.4.0.ebuild
new file mode 100644
index 000000000000..8bb6290f833a
--- /dev/null
+++ b/dev-python/confuse/confuse-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="https://github.com/beetbox/confuse"
+SRC_URI="https://github.com/beetbox/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/pyproject2setuppy[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx_rtd_theme'