summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-21 09:10:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-21 09:23:16 +0100
commit02e5fa85f4d6fc21d775e2ba0d43cc555638ebcb (patch)
tree369b097d853cc5a3c5cfce79b340be234d4d9241 /dev-python/construct
parentdev-python/alembic: Bump to 1.5.5 (diff)
downloadgentoo-02e5fa85f4d6fc21d775e2ba0d43cc555638ebcb.tar.gz
gentoo-02e5fa85f4d6fc21d775e2ba0d43cc555638ebcb.tar.bz2
gentoo-02e5fa85f4d6fc21d775e2ba0d43cc555638ebcb.zip
dev-python/construct: Bump to 2.10.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.61.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 6865c7ba1926..473454f86b45 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -3,3 +3,4 @@ DIST construct-2.10.57.tar.gz 1184585 BLAKE2B abaeebf5872cc97cc67d47cf79370fecdb
DIST construct-2.10.58.tar.gz 1184881 BLAKE2B d1dfa005542505b0a154f3c0ae74a1708747b1e7b9f5dc650b924169fa54620719bdf5bb868e616ae58e8890f547eaf3bad5b02ef1f7f7ffeeadffaa87413041 SHA512 8547847e3fa15c020ab7d178b229c5b93744b48497c4cf809a93527be5776eacd52783a0fa38583d694c262c119835c989fcbe0936eb247ca844d252c4bdebb5
DIST construct-2.10.59.tar.gz 1185999 BLAKE2B 35c861d5d4f5d68a158f25cffccda76621e0fe901e5f8bdf9c0aea61e3ddd2174c71767601be3533092a6a28748597cd1a044e4721436748b9a2dac81b81b41b SHA512 bf5867efdb9e1a27ddede6844f5f3466714e38dd97aae09c6990582989801605eebf90099fb3a0ab78deaed4f3b6be38421b635f6332461efd033d5fb8c2c1af
DIST construct-2.10.60.tar.gz 1185983 BLAKE2B e263c15db9d8055db854508f767906e51fb260c47e2df17e2786277a3ed66e9a8599f21299b21d0629997c6ce2afd7651e18aee4c7f22d3e38bdc5db5bd53bd4 SHA512 597e4fd9f0264450fe221e100041a897d25794bea4dd5cbf5f58df8a0829a34490daff10764e6329ade165df631ddce661dceae4417d8f55472b2fad2a53e53d
+DIST construct-2.10.61.tar.gz 1185872 BLAKE2B 03eb83b707f607f65f13f6430815af3f91f728e133cc1a889f4ff37e34b249cff8f8b13ffb764fbffbba2bec699ce94173e3b80498c42f8fc7628a125b659188 SHA512 dd25f9646d55c4914fbb506b795dced01a5a2d58a9d8378ceaa4d5ba666c9547e96f7a658e8d521ef9a3f53065e89b90e0c8560bc2eb4095b9ff8077b840eec4
diff --git a/dev-python/construct/construct-2.10.61.ebuild b/dev-python/construct/construct-2.10.61.ebuild
new file mode 100644
index 000000000000..8382a5e82e73
--- /dev/null
+++ b/dev-python/construct/construct-2.10.61.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm tests/test_benchmarks.py || die
+}
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}