summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 10:06:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 10:22:20 +0300
commit1fc281989ab281c82bed688dfdf57f676e2b150f (patch)
treee0246fa9c65bcbb6918068b0ef574c60f7579d47 /dev-python/cookies/cookies-2.2.1-r2.ebuild
parentdev-python/greenstalk: mark ALLARCHES (diff)
downloadgentoo-1fc281989ab281c82bed688dfdf57f676e2b150f.tar.gz
gentoo-1fc281989ab281c82bed688dfdf57f676e2b150f.tar.bz2
gentoo-1fc281989ab281c82bed688dfdf57f676e2b150f.zip
dev-python/cookies: Use PEP517 build, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cookies/cookies-2.2.1-r2.ebuild')
-rw-r--r--dev-python/cookies/cookies-2.2.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cookies/cookies-2.2.1-r2.ebuild b/dev-python/cookies/cookies-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..e4f8edf55df6
--- /dev/null
+++ b/dev-python/cookies/cookies-2.2.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Friendlier RFC 6265-compliant cookie parser/renderer"
+HOMEPAGE="https://gitlab.com/sashahart/cookies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ # https://gitlab.com/sashahart/cookies/merge_requests/2
+ "${FILESDIR}/cookies-2.2.1-fix-warnings.patch"
+
+ "${FILESDIR}/cookies-2.2.1-tests.patch"
+)
+
+distutils_enable_tests pytest