summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:48:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:49 +0100
commitdc6adf00a835d279221d46087d73a3661777f324 (patch)
treef12ea3687fdfd698eb7c598225f3784373b01f07 /dev-python/coreschema
parentdev-python/djangorestframework: Migrate to PEP517 build (diff)
downloadgentoo-dc6adf00a835d279221d46087d73a3661777f324.tar.gz
gentoo-dc6adf00a835d279221d46087d73a3661777f324.tar.bz2
gentoo-dc6adf00a835d279221d46087d73a3661777f324.zip
dev-python/coreschema: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coreschema')
-rw-r--r--dev-python/coreschema/coreschema-0.0.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/coreschema/coreschema-0.0.4-r1.ebuild b/dev-python/coreschema/coreschema-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..f839f7e41981
--- /dev/null
+++ b/dev-python/coreschema/coreschema-0.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Core Schema"
+HOMEPAGE="https://github.com/core-api/python-coreschema"
+SRC_URI="
+ https://github.com/core-api/python-coreschema/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest