summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 17:36:14 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 19:56:00 +0000
commitea4e17b3a5831451644db3105ebc2c9bb5aa5371 (patch)
tree14822957613558c2dde14e639fa2df4f2a1a333f /dev-python/corner/corner-2.0.1.ebuild
parentapp-portage/gentoolkit: Version bump (diff)
downloadgentoo-ea4e17b3a5831451644db3105ebc2c9bb5aa5371.tar.gz
gentoo-ea4e17b3a5831451644db3105ebc2c9bb5aa5371.tar.bz2
gentoo-ea4e17b3a5831451644db3105ebc2c9bb5aa5371.zip
dev-python/corner: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/corner/corner-2.0.1.ebuild')
-rw-r--r--dev-python/corner/corner-2.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/corner/corner-2.0.1.ebuild b/dev-python/corner/corner-2.0.1.ebuild
new file mode 100644
index 000000000000..45467d889f1d
--- /dev/null
+++ b/dev-python/corner/corner-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Make scatter matrix corner plots"
+HOMEPAGE="http://corner.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# missing expected test images in tar ball (2.0.1)
+RESTRICT=test