summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 16:21:55 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 16:42:14 +0300
commit1cd1c23463bef5b2f9c594c4fe00fc1056b357f7 (patch)
tree115d0ac6f0376b8a68f874586ac719b598b6404f /dev-python/cov-core
parentdev-python/sphinx-py3doc-enhanced-theme: eapi7 + py3_7 (diff)
downloadgentoo-1cd1c23463bef5b2f9c594c4fe00fc1056b357f7.tar.gz
gentoo-1cd1c23463bef5b2f9c594c4fe00fc1056b357f7.tar.bz2
gentoo-1cd1c23463bef5b2f9c594c4fe00fc1056b357f7.zip
dev-python/cov-core: eapi7 + py3_7
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/cov-core')
-rw-r--r--dev-python/cov-core/cov-core-1.15.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/cov-core/cov-core-1.15.0-r1.ebuild b/dev-python/cov-core/cov-core-1.15.0-r1.ebuild
new file mode 100644
index 000000000000..4c56dcdd1924
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.15.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://bitbucket.org/memedough/cov-core/overview"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"