summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:48:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:08 -0500
commit17f9572ab1ce28e2f0c2beaccb139e8e7898aed5 (patch)
treedc279699ed32a6059542ed5b5878a66f6df54d9c /dev-python/coverage/coverage-4.5.2.ebuild
parentdev-python/oslotest: 3.7.1 bump (diff)
downloadgentoo-17f9572ab1ce28e2f0c2beaccb139e8e7898aed5.tar.gz
gentoo-17f9572ab1ce28e2f0c2beaccb139e8e7898aed5.tar.bz2
gentoo-17f9572ab1ce28e2f0c2beaccb139e8e7898aed5.zip
dev-python/coverage: 4.5.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/coverage/coverage-4.5.2.ebuild')
-rw-r--r--dev-python/coverage/coverage-4.5.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/coverage/coverage-4.5.2.ebuild b/dev-python/coverage/coverage-4.5.2.ebuild
new file mode 100644
index 000000000000..9cc2e846b7d4
--- /dev/null
+++ b/dev-python/coverage/coverage-4.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ >=dev-python/setuptools-18.4[${PYTHON_USEDEP}]
+ test? (
+ dev-python/PyContracts[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ [[ "${PYTHON}" =~ pypy ]] && export COVERAGE_NO_EXTENSION=no
+ ${PYTHON} "${S}"/igor.py test_with_tracer py || die
+ ${PYTHON} "${S}"/igor.py test_with_tracer c || die
+}