summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-01 09:09:12 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-01 09:13:30 +0100
commit948dba875a5a912f463a7396b79c67505031ca36 (patch)
treeb43bff1692b477d52cb3dedb1f1329629b888ef2 /dev-python/coverage
parentdev-python/pylint: Bump to 2.7.2 (diff)
downloadgentoo-948dba875a5a912f463a7396b79c67505031ca36.tar.gz
gentoo-948dba875a5a912f463a7396b79c67505031ca36.tar.bz2
gentoo-948dba875a5a912f463a7396b79c67505031ca36.zip
dev-python/coverage: Bump to 5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-5.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index c34f8832694d..33497c684624 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,3 +1,4 @@
DIST coverage-4.5.4.tar.gz 385185 BLAKE2B 9d040bff13cebd1cb7147f15c3ec03bb08648cf801b5b2bb046a6b5bcadb3d3886be8bf0a624d225f25d10a5ca82fe5fb88f55e44e92a0a3285836b837972970 SHA512 ba534e04fe35cbadc4b16735f25c08f579a49a6677ec106680f222f2dfb3d0f1e011d0962f1c2108c375173ac4588bea1619ecda05ff9ba6fd888daddfd27b0e
DIST coverage-5.3.1.tar.gz 684457 BLAKE2B 82c8e311d85a6f758c46767957199e94099838e3c340f5da1472813a2877293245583cb190acc0139cddf3363ee5f299fb42f955c59912b80d9d1ece8cfb09fa SHA512 981ebc9f9490efe613edd68afdef83cb161b303e6de266335ffd2d1d3634bd5a088cbff249b0243071b55cb4f31b4b0c7537b5764660ccc86a7059307badd571
DIST coverage-5.4.tar.gz 687727 BLAKE2B 54c9e605eaed551aff0c6764bf2747e2ce64a7c0596cb78cb4ad6998c4b7d79fe31bfe98eb240aee4c838dde6a4536f8e84d00c14846bb671b51b28168a96947 SHA512 c682806bce603fff1ff09234c72e17370093192053961656f06ef4bcc7928f052ef4a350e80687c640d7608a22f4f3434e1836d83674eebca53459745838f519
+DIST coverage-5.5.tar.gz 691258 BLAKE2B 66bf340956b760d996ce424f977b407eb74062db56108e4910459dbcb7c271820ca655a648021763aede1c4d87c44524cea0cb34f969f203f630d48cf15b05b4 SHA512 fb78b4920a2f18afb9545a6f13910f491708443965881954fff6ee8553ab3d6bd898f7a95df1091435e8d5627ac850b880a6233e716a6acb934ecc195ec2ee52
diff --git a/dev-python/coverage/coverage-5.5.ebuild b/dev-python/coverage/coverage-5.5.ebuild
new file mode 100644
index 000000000000..6a99cbf4e39c
--- /dev/null
+++ b/dev-python/coverage/coverage-5.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+#IUSE="test"
+# The tests are impossible to appease. Please run them externally
+# via tox. Or fix the ebuild if you have hours of time to spend
+# on something utterly useless.
+RESTRICT="test"
+
+#BDEPEND="
+# test? (
+# dev-python/PyContracts[${PYTHON_USEDEP}]
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/hypothesis[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+# )
+#"
+
+src_prepare() {
+ # avoid the dep on xdist, run tests verbosely
+ sed -i -e '/^addopts/s:-n3:-v:' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ pushd tests/eggsrc >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+
+ "${EPYTHON}" igor.py zip_mods || die
+ "${EPYTHON}" igor.py test_with_tracer py || die
+
+ # No C extensions under pypy
+ if [[ ${EPYTHON} != pypy* ]]; then
+ cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
+ "${EPYTHON}" igor.py test_with_tracer c || die
+ fi
+
+ # clean up leftover "egg1" directory
+ rm -rf build/lib/egg1 || die
+}