summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-18 11:23:06 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 12:18:47 +0200
commita334a2fc4d89b356c8d947238c8d9ff1dfd2b2f4 (patch)
tree556056ad8a5ca34d6ba9eae54e17167242250386 /dev-python/crcmod
parentapp-crypt/gnupg: ppc64 stable wrt bug #689392 (diff)
downloadgentoo-a334a2fc4d89b356c8d947238c8d9ff1dfd2b2f4.tar.gz
gentoo-a334a2fc4d89b356c8d947238c8d9ff1dfd2b2f4.tar.bz2
gentoo-a334a2fc4d89b356c8d947238c8d9ff1dfd2b2f4.zip
dev-python/crcmod: EAPI=7, Py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crcmod')
-rw-r--r--dev-python/crcmod/crcmod-1.7-r3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/crcmod/crcmod-1.7-r3.ebuild b/dev-python/crcmod/crcmod-1.7-r3.ebuild
new file mode 100644
index 000000000000..14a3f65d101e
--- /dev/null
+++ b/dev-python/crcmod/crcmod-1.7-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CRC Generator module"
+HOMEPAGE="http://crcmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DOCS=( changelog test/examples.py )
+
+python_test() {
+ "${EPYTHON}" test/test_crcmod.py -v || die "Tests fail with ${EPYTHON}"
+}