summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-09 08:47:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:22:52 +0300
commit0889152e58187d0dd763875b38d3d4270a3a6259 (patch)
tree803725bf967b02e4e455d58bc1b61977aa87bd93 /dev-python/croniter
parentdev-python/dulwich: add 0.20.46 (diff)
downloadgentoo-0889152e58187d0dd763875b38d3d4270a3a6259.tar.gz
gentoo-0889152e58187d0dd763875b38d3d4270a3a6259.tar.bz2
gentoo-0889152e58187d0dd763875b38d3d4270a3a6259.zip
dev-python/croniter: add 1.3.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/croniter')
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-1.3.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index 18712a118e47..ccd0b8119f65 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1 +1,2 @@
DIST croniter-1.3.5.tar.gz 38606 BLAKE2B 45586ef4ef6622caca3611fd596818a875a451ade6353cf4a99219f38ab76e72656c885bd61238670a809203d487d78d884d700c5e2e4c6eb1bdf44dfc14a1c4 SHA512 9b59334f8537cd5b48e17be2c83fcb78f2c0a8c62b7c28091600c84cf202e6847d7d1d40ff5ebb57cac3a713013ca247620e348aa9f3a408483cf4110a88545f
+DIST croniter-1.3.7.tar.gz 38853 BLAKE2B 2a05a023300a1e90824fdfe444eb1b2e43889c99d5b070329fc9f11c9e1807c4bb81a0c27c17d3aa92130d91c949e8515b76c7d927a5c583a3a86172f24be446 SHA512 c0157fc3d5b88ae66ee9871bc9e18b835a71f2fe85d66b9e92b05329652e150bdd823976a495b30e62050fa21d3353cffb090c8c99b74f79eba6dfa87ffcb11a
diff --git a/dev-python/croniter/croniter-1.3.7.ebuild b/dev-python/croniter/croniter-1.3.7.ebuild
new file mode 100644
index 000000000000..07402f10627d
--- /dev/null
+++ b/dev-python/croniter/croniter-1.3.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="
+ https://github.com/kiorky/croniter/
+ https://pypi.org/project/croniter/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest