summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-06 04:28:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-06 04:28:16 +0100
commitadcae807aa65b5d6baa9b2b9bfcf11f962dacc73 (patch)
tree08eb4e51ba5c6bdab5834e165bb4a36f1b3458ad /dev-python/cryptography/cryptography-1.7.2.ebuild
parentdev-python/cryptography-vectors: Bump to version 1.7.2 (diff)
downloadgentoo-adcae807aa65b5d6baa9b2b9bfcf11f962dacc73.tar.gz
gentoo-adcae807aa65b5d6baa9b2b9bfcf11f962dacc73.tar.bz2
gentoo-adcae807aa65b5d6baa9b2b9bfcf11f962dacc73.zip
dev-python/cryptography: Bump to version 1.7.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/cryptography/cryptography-1.7.2.ebuild')
-rw-r--r--dev-python/cryptography/cryptography-1.7.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/cryptography/cryptography-1.7.2.ebuild b/dev-python/cryptography/cryptography-1.7.2.ebuild
new file mode 100644
index 000000000000..b156293edf4e
--- /dev/null
+++ b/dev-python/cryptography/cryptography-1.7.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.4.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy{,3})
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ distutils_install_for_testing
+
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}